Fully-Coupled Thermo-Mechanical Analysis

Type of solver: ABAQUS CAE/Standard
Adapted from: ABAQUS Example Problems Manual

Extrusion of a Cylindrical Aluminium Bar with Frictional Heat Generation

Problem Description:

The figure below shows the cross-sectional view of an aluminium cylindrical bar placed within an extrusion die. The bar has an initial radius of 100 mm and a length of 300 mm, and its radius is to be reduced by 33% through an extrusion process. The die can be assumed as an isothermal rigid body. During the extrusion process, the bar is forced downwards by 250 mm at a constant displacement rate of 25 mm s$^{-1}$. The generation of heat attributable to plastic dissipation inside the bar and the frictional heat generation at the die-workpiece interface causes temperature of the workpiece to rise. When extrusion is completed, the workpiece is allowed to cool in the ambient air. The ambient surrounding is at 20 °C, with a coefficient of heat transfer of 10 W m$^{-2}$ K$^{-1}$.

Formulate an axisymmetric FE model to predict (i) the geometry of the deformed bar, (ii) the plastic strain distribution and (iii) the temperature evolution, at various stages of the extrusion process.
SOLUTION:

- Start ABAQUS/CAE. At the Start Session dialog box, click Create Model Database.
- From the main menu bar, select Model→Create. The Edit Model Attributes dialog box appears, name the model TM_Coupled

A. MODULE → PART

We will construct an axisymmetric model consisting of a deformable workpiece and a rigid die.

(a) To sketch the aluminium alloy workpiece

1. From the main menu bar, select Part→Create
2. Name the part Workpiece. Use the settings are shown in Fig.A1. Ensure that the Modeling Space is set to Axisymmetric and the Type as Deformable.
3. Sketch the Workpiece, the 4 vertices as shown in Fig.A2 are (0,0), (0.1,0), (0,0.3) and (0.1,0.3) in metres.

Note: When building an axisymmetric model, it is important to observe the position of various parts in relation to the axis of symmetry.
(b) To sketch the rigid die

1. From the main menu bar, select **Part→Create**

2. Name the part **Die**. Apart from the name, all the other settings are the same as in **Fig.A1**. *Note:* Although the die is meant to be a rigid body in this analysis, here we choose to first build it as a deformable body and later apply a **Rigid body** constraint (Section E (c)).

3. Sketch the **Die** using the vertices given in **Fig.A3**. *Note:* Observe that all coordinates are followed correctly, so that the assembly of the workpiece and die can be carried out correctly later.

4. We also need to add a reference point to the die part to be used in rigid body constraint. From the main menu bar, select **Tools→Reference Point**. Pick point (0.067, -0.18) as denoted in **Fig.A3**, note that a yellow **RP** symbol appears.
B. MODULE → PROPERTY

(a) To enter material properties of the workpiece:-

1. From the main menu bar, select **Material→Create**

2. Name the material **Aluminium**.

3. Create the following material properties:

   (i) **General→Density**  2700 (kg m⁻³)

   (ii) **Thermal→Conductivity**

      - Under **Type** choose **Isotropic**
      - Toggle on **Use temperature-dependent data**

      (NB. Conductivity in W m⁻¹ K⁻¹, Temp in °C)

      and use data shown in **Fig.B1**.

   (iii) **Thermal→Inelastic Heat Fraction**  0.9

   (iv) **Thermal→Specific Heat**  880 (J kg⁻¹ K⁻¹)

   (v) **Mechanical→Elastic**

      Under **Type** choose **Isotropic**
      
      **Young’s Modulus**: 69×10⁹ (Pa)
      **Poisson’s Ratio**: 0.33

   (vi) **Mechanical→Expansion**

      Under **Type** choose **Isotropic**
      
      **Reference temperature**: 20 °C
      **Expansion Coeff alpha**: 8.42×10⁻⁵ (K⁻¹)
(vii) Mechanical → Plasticity → Plastic

Under **Hardening** choose **Isotropic** (Fig.B2).

Toggle on **Use Temperature-dependent data**

The complete set of data is given in Table 1.

*(Note: The list of data can also be directly imported into ABAQUS/CAE if an ASCII text file is available (*NOT* provided in this exercise). To do this, right click within the table and choose Read from File 📦)*

**Table 1: Temperature-dependent flow stress of Aluminium**

<table>
<thead>
<tr>
<th>Yield stress</th>
<th>Plastic strain</th>
<th>Temp</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.00E+07</td>
<td>0</td>
<td>20</td>
</tr>
<tr>
<td>9.00E+07</td>
<td>0.125</td>
<td>20</td>
</tr>
<tr>
<td>1.13E+08</td>
<td>0.25</td>
<td>20</td>
</tr>
<tr>
<td>1.24E+08</td>
<td>0.375</td>
<td>20</td>
</tr>
<tr>
<td>1.33E+08</td>
<td>0.5</td>
<td>20</td>
</tr>
<tr>
<td>1.66E+08</td>
<td>1</td>
<td>20</td>
</tr>
<tr>
<td>1.66E+08</td>
<td>2</td>
<td>20</td>
</tr>
<tr>
<td>6.00E+07</td>
<td>0</td>
<td>50</td>
</tr>
<tr>
<td>8.00E+07</td>
<td>0.125</td>
<td>50</td>
</tr>
<tr>
<td>9.70E+07</td>
<td>0.25</td>
<td>50</td>
</tr>
<tr>
<td>1.10E+08</td>
<td>0.375</td>
<td>50</td>
</tr>
<tr>
<td>1.20E+08</td>
<td>0.5</td>
<td>50</td>
</tr>
<tr>
<td>1.50E+08</td>
<td>1</td>
<td>50</td>
</tr>
<tr>
<td>1.51E+08</td>
<td>2</td>
<td>50</td>
</tr>
<tr>
<td>5.00E+07</td>
<td>0</td>
<td>100</td>
</tr>
<tr>
<td>6.50E+07</td>
<td>0.125</td>
<td>100</td>
</tr>
<tr>
<td>8.15E+07</td>
<td>0.25</td>
<td>100</td>
</tr>
<tr>
<td>9.10E+07</td>
<td>0.375</td>
<td>100</td>
</tr>
<tr>
<td>1.00E+08</td>
<td>0.5</td>
<td>100</td>
</tr>
<tr>
<td>1.25E+08</td>
<td>1</td>
<td>100</td>
</tr>
<tr>
<td>1.26E+08</td>
<td>2</td>
<td>100</td>
</tr>
<tr>
<td>4.50E+07</td>
<td>0</td>
<td>150</td>
</tr>
<tr>
<td>6.30E+07</td>
<td>0.125</td>
<td>150</td>
</tr>
<tr>
<td>7.50E+07</td>
<td>0.25</td>
<td>150</td>
</tr>
<tr>
<td>8.90E+07</td>
<td>0.5</td>
<td>150</td>
</tr>
<tr>
<td>1.10E+08</td>
<td>1</td>
<td>150</td>
</tr>
<tr>
<td>1.11E+08</td>
<td>2</td>
<td>150</td>
</tr>
</tbody>
</table>
(b) To enter material properties of the die:-

1. From the main menu bar, select **Material → Create**
2. Name the material **Die-Material**
3. Create the following material properties:

   **Note:** Since the die will be modelled as a rigid body and heat flow into the die is not modelled, the properties entered here will be inconsequential. However, non-zero values must be entered so that the ABAQUS/CAE solver can proceed.

   (i) **General → Density**  2700 (kg m\(^{-3}\))

   (ii) **Thermal → Conductivity**  200 (W m\(^{-1}\) K\(^{-1}\))

   (iii) **Thermal → Specific Heat**  880 (J kg\(^{-1}\) K\(^{-1}\))

   (iv) **Mechanical → Expansion**

      Under **Type** choose **Isotropic**

      **Reference temperature:**  20 (°C)

      **Expansion Coefficient - alpha:** 8.42×10\(^{-5}\) (K\(^{-1}\))

   (v) **Mechanical → Elastic**

      Under **Type** choose **Isotropic**

      **Young’s Modulus:**  200×10\(^9\) (Pa)

      **Poisson’s Ratio:**  0.3

(c) To create the sections and assign them to the parts

1. From the main menu bar, select **Section → Create**
2. Name it **Section-workpiece** *(Fig.B3)*. For **Category**, choose **Solid**, and set **Type** as **Homogeneous**.
3. In the **Edit Section** dialogue box *(Fig.B4)*, under **Material** pick **Aluminium**.
4. Now create a section for the die, call it **Section-die**.
5. Assign the sections to the relevant parts.
C. MODULE ➔ ASSEMBLY

1. From the main menu bar, select Instance ➔ Create

2. First create an instance of the Die part. Under Instance Type, make sure to select Independent (mesh on instance). Toggle off Auto-offset from other instances.

3. Then create an instance of the Workpiece part, also as an independent instance. Make sure that Auto-offset from other instances is set as off, see Fig.C1.

4. The complete assembly of the die and workpiece is depicted on the left panel of Fig.C1.

D. MODULE ➔ STEP

This fully-coupled thermal displacement transient analysis will consist of an initial step (exist by default) plus 4 additional steps (to be created in this section). Fig.D1 shows the Step Manager dialogue box with all the steps correctly set up.

Important: The “Ngeom” option must be enabled to account for large strain plastic deformations.
(a) To create Step-1: Stabilise workpiece inside die

1. From the main menu bar, select Step→Create

2. Name it Step-1 (Fig.D2). The Procedure type is General→Coupled temp-displacement

3. In Edit Step dialog box, under the Basic tab (Fig.D3), enter Stabilise workpiece inside die as the Description. To account for large plastic deformation, toggle on Nlgeom. To consider time-dependent plasticity, toggle on Include creep/swelling/viscoelastic behavior.

4. In Edit Step dialog box, click on the Incrementation tab (Fig.D4) and reduce the Initial Increment size to 0.1. Toggle on Max. allowable temperature change per increment and enter 100.

5. Accept the default settings under the Other tab.

(b) To create Step-2: Extrusion

Create Step-2. As of Step-1, the Procedure type is Coupled temp-displacement. Figs.D5 and D6 show the parameters to be used.
(c) To create Step-3: Remove contact pairs

Create Step-3 and fill out the parameters as in Figs. D7 and D8.

(d) To create Step-4: Let workpiece cool down

Create Step-4 and fill out the parameters as in Figs. D9 and D10.
Module 4

**E. MODULE \( \rightarrow \) INTERACTION**

(a) To create surfaces for interaction

1. From the main menu bar, select **View**→**Assembly Display Options**

2. Click the **Instance** tab, toggle off the visibility of **Workpiece-1**, see Fig.E1. Click **OK**.

3. From the main menu bar, select **Tools**→**Surface**→**Create**.

4. Name the surface **Surf-die-Contact**, pick the 5 edges designated in Fig.E2. **Tip:** To make multiple selections, hold down the Ctrl-button while clicking.

5. Return to **Assembly Display Options** to toggle on the visibility of **Workpiece-1**, then toggle off **Die-1**. Click **OK**.

6. Create a surface called **Surf-workpiece-Vertical**, i.e. the vertical edge that comes into contact with the die, see Fig.E3.

7. Create a surface called **Surf-workpiece-Horizontal**, as designated in Fig.E3.

8. Finally, create another surface called **Surf-workpiece-Convect** that consists of 3 edges denoted in Fig.E4.

9. Toggle on both instances when finished assigning all surfaces.
(b) To create the interaction property

1. From the main menu bar, select Interaction ➔ Property ➔ Create

2. Name it IntProp-1. Under Type, select Contact.

3. In the Edit Contact Property dialogue box (Fig.E5), add the following properties:

   (i) Mechanical ➔ Tangential Behavior
       • For Friction formulation, choose Penalty
       • Friction Coeff: 0.1

   (ii) Thermal ➔ Heat Generation
       • Use 0.5, 0.5

(c) To create a rigid body constraint for the die

1. From the main menu bar, select Constraint ➔ Create

2. Name the constraint Die-RigidBody. Under Type, select Rigid body.

3. The Edit Constraint dialogue box appears (Fig.E6). Under Region type, choose Body(elements) and then pick the die region.

4. For Reference Point, pick the yellow point denoted as RP (see Fig.A3), i.e. the reference point of the die.

5. Toggle on Constraint selected regions to be isothermal.
(d) To create the interactions

We will create 3 interactions, the end result is shown in Fig.E7. Note that not all interactions are active at all steps.

- Thermal film interaction
  1. From the main menu bar, select Interaction → Create
  2. Name it CONVECT. Select Step-4 and Surface film condition, see Fig.E8.
  3. To pick the surface, click on the button located at the right hand corner of the prompt area, then select Surface-workpiece-Convect.
  4. In the Edit Interaction dialogue box, enter Film coefficient as 10 (W m\(^{-2}\) K\(^{-1}\)) and Sink temperature as 20 (°C).
• **Mechanical interactions**

1. From the main menu bar, select Interaction ➔ Create

2. Name it INTER-H. Select Step: Initial and Surface-to-surface contact (Standard), see Fig.E11.

3. For the master surface, select Surf-die-Contact (i.e. choose the stiffer of the pair)

4. Choose the slave type as Surface, then select Surf-workpiece-Horizontal.

5. The Edit Interaction dialogue box (Fig.E12) appears. Set Degree of smoothing for master surface as 0.48. Accept the rest of the default settings. Note that the Contact interaction property is IntProp-1 which was created earlier in (a).

6. Now using similar procedures, create an interaction for INTER-V. Assign Surf-die-Contact as the master surface and Surf-workpiece-Vertical as the slave.

7. We also need to make INTER-H and INTER-V inactive during Step-3 (Remove contact pairs) and Step-4 (Let workpiece cool down). From the main menu bar, select Interaction ➔ Manager to bring up the Interaction Manager dialogue box (Fig.E7). Click on the box that corresponds to INTER-H and Step-3, then click on Deactivate. Repeat for INTER-V.
F. MODULE ➔ LOAD

(a) To create the boundary conditions

- We will create 5 boundary conditions (BCs), the end result is shown in Fig.F1. Four of which are displacement boundary conditions (Disp-BC) and the last is a temperature boundary condition (Temp-BC). Note that not all BCs are active at all times.

(i) Disp-BC-1

1. From the main menu bar, select BC ➔ Create

2. Name it Disp-BC-1 (Fig.F2). Assign to Step: Step-1. Category: Mechanical ➔ Displacement/Rotation

3. Pick RP, the reference point of the die.

4. Set $U_1 = U_2 = U_3 = 0$ (To ensure that the die remains static throughout the simulation), see Fig.F3.
(ii) Disp-BC-2

1. From the main menu bar, select BC→Create


3. Pick the edge corresponding to the axis of the workpiece, see Fig.F4.

4. Set $U_1 = 0$ (To ensure that the workpiece remains axisymmetric throughout the simulation).

(iii) Disp-BC-3

1. From the main menu bar, select BC→Create


3. Pick the edge corresponding to the top surface of the workpiece, see Fig.F5.

4. Set $U_2 = -0.000125$ (m)
   
   Note: A relatively small vertical displacement is assigned to the top surface of the workpiece at the start of the simulation to establish contacts at the interfaces.

5. Deactive this BC for Step-2 and beyond, use the Boundary Condition Manager to do this - see Fig.F1.
(iv) **Disp-BC-4**

1. From the main menu bar, select BC → Create
2. Name it Disp-BC-4. Assign to Step: Step-2. **Category:** Mechanical → Displacement/Rotation
3. Pick the edge corresponding to the top surface of the workpiece, see Fig.F6.
4. Set \( U_2 = -0.25 \) (Displace the workpiece by 250 mm downwards, i.e. to simulate the extrusion process)

(v) **Temp-BC-1**

1. From the main menu bar, select BC → Create
2. Name it Temp-BC-1. Assign to Step: Step-1. **Category:** Other → Temperature
3. Pick the RP on the die, see Fig.F7.
4. Set the Magnitude as 20 (°C). The temperature of the die remains constant throughout simulation since we are not accounting for heat transfer into the die.

(b) **To create a thermal field for the workpiece**

1. From the main menu bar, select Predefined Field → Create
2. Name it Field-workpiece. Assign to Step: Initial. **Category:** Other → Temperature
3. Pick the Workpiece instance. In the Edit Field dialogue box, enter 20 (°C) as the Magnitude. This is the initial temperature, the temperature in subsequent steps will be computed.
**G. MODULE → MESH**

(a) To mesh the workpiece:-

1. First hide the die in the viewport: From the main menu bar, select **Interaction → Assembly Display Options → Instance**, toggle off the die instance.

2. From the main menu bar, select **Seed → Edge By Number**.

3. Assign 10 seeds to the horizontal edge and 30 seeds to the vertical edge, see **Fig.G1**.

4. From the main menu bar, select **Mesh → Controls**. Use **Quad** elements and apply **Structured** (green) technique (Fig.G2).

5. From the main menu bar, select **Mesh → Element Type**. **Element Library**: **Standard**. Under **Family**, choose **Coupled Temperature-Displacement**. Use element type **CAX4T**, see **Fig.G3**.

6. From the main menu bar, select **Mesh → Mesh Instance**. Select the workpiece instance to generate the mesh, it should resemble **Fig.G4**.
(b) To mesh the die:-

1. Now hide the workpiece and make the die instance visible.

2. Seed the edges of the die as shown in Fig.G5.

   Note: To reduce computation time, we apply relatively coarse mesh for the die since it acts as a rigid body here and heat transfer across the interface is not accounted for in this analysis.

3. Under Mesh Control, choose Quad, Structured and toggle on Minimize the mesh transition (Fig.G2).

4. Apply CAX4T element type.

5. The generated mesh of the assembly is shown in Fig.G6.

H. MODULE → JOB

1. From the main menu bar, select Job→Create

2. Enter Job-Extrusion as the job name.

3. Submit the job and monitor the progress. This analysis can take between 15 and 30 minutes depending on your system.

4. When the job is completed, from the Job Manager dialogue box, click on Results.
I. MODULE   VISUALIZATION

1. To display the deformed configuration after Step-2 of the analysis (Fig.I1): from the main menu bar, select Plot   Deformed Shape, then use the control buttons in the context bar to scroll through the ODB frames.

2. To display plastic strain contours at the end of Step-2, select Result   Field Output, select PEEQ, and use the Step/Frame button at the top of the dialogue box to choose the step name (Fig.I2).

3. To show the temperature field at the end of Step-2, select NT11 in Result   Field Output, the result is shown in Fig.I3.

4. To generate a 3-D view of the axisymmetric model: from the main menu bar, select View   ODB Display Option, then click on the Sweep & Extrude tab, toggle on Sweep elements, enter the angles and segment specification. An example is depicted in Fig.I4 with angles from 0° to 270°.
Optional questions

1. Explore the sensitivity of the model predictions towards the choice of element types and meshing strategies.

2. Show how you can monitor and record the temperature history at a specific node located in the vicinity of the hot zone where the maximum temperature is over 100 °C (see Fig.13).

3. Show how you can model the effects of heat transfer from the workpiece into the die.

4. If you’re interested in studying the effects of strain rates, what extra information will be needed?

5. Investigate the contribution of heat generation due to friction towards the overall temperature rise.